Talk:No Linux

From Openmoko

Jump to: navigation, search
Using VirtualBox with Linux running?

I just got my Neo Freerunner phone yesterday, and i enjoy it very much.

When i tried to backup the entire system that it came with, i first tried dfu-util/usb (installed with apt-get) on Linux Mint, using an Asus Eee netbook, this didn't go well for some reason. I would get errors -84 and -71, even with different cables (The 84 error was with the cable that came with the Neo).

Now i'm attempting to run the backup on my main computer, which is running Vista x64. I'm using a VirtualBox vm running Ubuntu 11.10, and so far it seems to be going ok. However when i did install dfu-util only, using apt-get install, first time it failed at Resetting USB, but that could be because i had just added the Neo to the virtualbox usb filter.

I then installed the following packages listed on with

sudo apt-get install libusb-dev autogen pkg-config autotools-dev autoconf automake

instead of just the previous

sudo apt-get install dfu-util

And after that dfu-util seems to be doing ok, but i do not know if it's because the other packages i installed or just the reboot of the VM. The usb id detected seems to be the same as quoted on the Backup page, and i think i'm around halfway or so on the rootfs at the moment (kernel went without errors apparently).

I do not have any way of checking if the backups are valid at the moment i think. But maybe someone can test this better?

Morten 12:29, 26 January 2012 (UTC)

Personal tools