Talk:Neo FreeRunner Wifi

From Openmoko

Jump to: navigation, search

Using the GUI on 2008.8

I didnt find any file named volatives.cache in /etc/ as the wiki implies, I did however find a volatile.cache which I renamed and now I can see wireless networks along with their signal strenght but I still cant connect to them. I also tried using lint-wifi but I get an error when trying to do opkg install lint-wifi, it says "an error ocurred, return value: 2" I installed mofi-wifi successfully but it crashes whenever I try to run it, so I cant even open it. I remember campwifi used to work great in the pre 2008.08 image of the ASU but I cant seem to find the package anywhere, was it included as the wifi gui in 2008.08? I havnt been very succesful when trying to connect to the wifi through the console but frankly I havnt tried much since I get easily annoyed with the qtopia keyboard.--Fice 18:50, 28 August 2008 (UTC)

Passphrase issues:

I have noticed that with wireless sometimes it works better to use the password hash in the wpa_supplicant.conf instead of the ascii text. You can use the wpa_passphrase utility (I don't know if this is included in the GTA02 or not as I don't have one) to generate the hash for the passphrase.

techiem2@escape-pod ~ $ wpa_passphrase MYWIFI "my passphrase" 
        #psk="my passphrase"

Of course you would probably want to redirect output to the end of your wpa_supplicant.conf (wpa_passphrase MYWIFI "my passphrase">>/etc/wpa_supplicant/wpa_supplicant.conf).

--techiem2 19:12, 3 July 2008 (UTC)


disabling wifi on startup

What would be the cleanest way to not enable wifi on startup? -- Relet 20:31, 9 July 2008 (UTC)

wpa_supplicant tips

These tips are universally valid on 2007.2, ASU, qtopia, and most likely FSO.

Weird ioctl messages

Ignore them, they seemingly have no effect. eg:

"ioctl[SIOCSIWENCODEEXT]: Operation not supported"

wpa_supplicant times out


Trying to associate with 00:1d:5a:e8:00:00 (SSID='2WIRE915' freq=2432 MHz)
Authentication with 00:1d:5a:e8:00:00 timed out.

What you need to do is re-specify the essid manually:

iwconfig eth0 essid "2WIRE915"

And it will then immediately connect and authorise with WPA/TKIP.

default route issues

Due to the way the FR configures its usb0 interface, it creates a default route. You will need to delete this in order to use wifi (or gprs/bluetooth-pan, I imagine):

route del default gw

Hope this helps others. Ieatlint 22:53, 12 July 2008 (UTC)

wpa-psk modes

On my home wireless setup, I was unable to connect to my access point while it was setup for WPA-PSK/AES or WPA2-PSK/AES. Once I reconfigured it for WPA-PSK/TKIP my FR conected immediately. If it turns out to be relevant, my access point at home is a Linksys WRT54GL running Tomato 1.19.

New page title suggestion

Does anyone object to renaming this page? I propose dropping the GTA02 prefix. GTA02 is jargon. And there's no GTA01_WLAN page, as the prefix implies. And how about "Wireless networking" instead of the "WLAN" abbreviation? --Joseph M. Jarvis 15:31, 21 July 2008 (UTC)

Remove random comments

"Success stories" really don't belong on here. At best, they can go on the talk page. And please if the various commands on this talk page are relevant, they should be integrated into the main content, or discarded as old. And yes, please rename as appropriate.

Success stories

July 23, 2008

wpa_supplicant 0.6.3-r1 works for me with WPA and WPA2 (with PSK) using the config file template on this page. Unlike the comment above, udhcpc is updating /etc/resolver.conf correctly for me (perhaps this is an old problem).

Bringing up wpa_supplicant manually or using "ifup eth0" with the wpa-conf option set in /etc/network/interfaces works for me. If usb0 was already up when running "ifup eth0" you'll end up with 2 default routes which can cause problems. To solve this either take usb0 down first or run "ip route del default dev usb0" to remove the default route to usb0.

July 19, 2008

I've had repeated success with:

# ifconfig eth0 up
# iwconfig eth0 essid any
# iwconfig eth0 key '...'
# iwconfig eth0 essid '...'
# udhcpc eth0
# ifconfig usb0 down; ifconfig usb0 up

Hope that helps someone. This is for WEP.

It worked for me as well (at last!!!) jolus 19:19, 4 August 2008 (UTC)

July 26, 2008

I've been able to connect to a variety of networks including WPA2 without too much difficulty. Follow the above steps in configuring your wpa_supplicant.conf and adding the line to load the supplicant in /etc/network/interfaces.

My sample WPA2 configuration is as follows:

  1. WPA2


 pairwise=CCMP TKIP
 group=CCMP TKIP


That configuration will allow you to connect to a WPA2-Personal network with TKIP key encryption.

The "ifup eth0" command will connect you via WiFi. If you don't get a lease the first time, try again. Sometimes the configuration is a little too slow and DHCP tries to get a lease before a successful connection to your access point has been established.

The following may be helpful in order to scan available networks :

# iwlist eth0 scan

SSH (dropbear) and LISTEN on all interfaces

I think the line in /etc/default/dropbear should better be changed to


without the IP a "netstat -an | fgrep 22" shows very ugly results; in any case the wpa_supplicant is working now fine for me in WEP and WPA-PSK modes; what is missing is some icon for bringing up the Wifi as "ifup eth0"

Wireless GPRS router

Is it possible to turn a GTA02 into a wireless gprs router, so it can be used as an emergency access point in case of ISP failure? I can't figure out, how to switch internal ar6000 into master mode. Do I need some special utility, like wlanconfig for other atheros/madwifi chips?

Remove defaults or explain them?

According to /usr/share/doc/wpasupplicant/README.wpa_supplicant.conf.gz the first lines of the example wpa configuration are all default:


Shouldn't these defaults be removed or explained if they serve a purpose? Bram

Personal tools