Talk:Manual Debian

From Openmoko

Jump to: navigation, search




Why don't we boot from NAND?

I do - works fine--JoSch 09:51, 28 December 2008 (UTC)

What's the reason for two partitions? Is it because ext2load was broken? Can we just upgrade u-boot and use one partition?

yes, it's a uboot thingy and only valid for gta02 - just use what works for you--JoSch 09:51, 28 December 2008 (UTC)

Is there any need for a swap partition?

--Brian 252 15:22, 8 August 2008 (UTC)

Some say it helped. Jidanni 02:38, 3 December 2008 (UTC)

Touch screen calibration

Few days ago there was added calibration for gta02. It doesn't work correctly on my freerunnuer (the mouse pointer doesn't move where I click ant the touchscreen area is about 1/3 smaller then the screen). I tried /etc/pointercal from qtopia and openmoko but it is the same as with parameters from this wiki. Has somebody a tip how to fix this?

--Jakubzeman 07:42, 8 August 2008 (UTC)

works with tslib from experimental--JoSch 09:51, 28 December 2008 (UTC)

Sound --Dbmoodb 13:55, 21 August 2008 (UTC) (if it doesn't work for you... try these alsa states or the ones posted below from

If the sound card is configured properly but there's no sound coming out of the Freerunner, it most likely helps to restore an appropriate statefile from the tgz above which are also available on the Openmoko svn (/trunk/src/target/audio/om-gta0*).

For simple sound output to the internal stereo speakers, do:

alsactl -f /path/to/statefiles/stereoout.state restore

--Tanuva 12:59, 21 August 2008 (UTC)

Problems Making This Work

I tried the instructions for loading Debian on my Freerunning and was disappointed to find it didnt work for me. I tried it twice, once with an Ext2 partition on the SDCARD and once with out, about a week ago, both gave exactly the same result. Its a very slow process too. The result when booting is that the phone brings up the openmoko logo , then a completly white screen and then goes back to the openmoko logo, it continues doing this ad-infinitum. It seems like the uboot image is wrong (=invalid) but I cant see how to fix this. Its still possible to boot original OS but via NOR screen. (Boot from card is the default now.)

Is there no chance of a binary debian image or starter image that can go into flash? I have flashed my phone many times with kernel and jffs2 images and although described as a "major" thing to do, it has always worked so far. Ive looked everywhere for a Debian image and cannot find.

Any comments appreciated.

The above problem can be resolved as follows

I had the same problem, and got the hint from Julian Köpke, who suggested the following and it works.

Your uboot version is too old. You can get the newest uboot image and then follow these instructions --Nagarjuna 10:14, 13 September 2008 (UTC)

Personal tools