Talk:Flashing the GSM Firmware

From Openmoko

(Difference between revisions)
Jump to: navigation, search
Line 29: Line 29:
 
I flashed 6 out of our 8 Freerunner V.6 according to the GSM/Flashing- guide. I had no problems and the previously useless 3G- SIMs are  
 
I flashed 6 out of our 8 Freerunner V.6 according to the GSM/Flashing- guide. I had no problems and the previously useless 3G- SIMs are  
 
working fine now. It seems like the 3G- SIM Issue, our beloved #666, is solved. You should point it out clearly. I heard a lot of users complain about this. The solution is simple and well hidden on the website. By the way, i have new 3G- SIM cards of the following german providers running without problems (O2, T- Mobile, E-Plus, Vodafone). Before the flashing procedure the Vodafone cards were not detected. Good work guys... thanks!  
 
working fine now. It seems like the 3G- SIM Issue, our beloved #666, is solved. You should point it out clearly. I heard a lot of users complain about this. The solution is simple and well hidden on the website. By the way, i have new 3G- SIM cards of the following german providers running without problems (O2, T- Mobile, E-Plus, Vodafone). Before the flashing procedure the Vodafone cards were not detected. Good work guys... thanks!  
--[[User:Reiner|Reiner]]
+
[[User:Reiner|Reiner]]
  
 
== Works now with new gsm firmware moko10beta2 with O2 in Germany ==
 
== Works now with new gsm firmware moko10beta2 with O2 in Germany ==

Revision as of 03:40, 21 November 2008

i recive instead of

"Program: (34 sectors, 267*8k=2136k) (*******************) ok"

this

"Program: (0 sectors, 0*8k=0k) () ok"

iam currently reflashing the old firmware, that seems to work.

iam using an non-us gsm-freerunner (recived yesterday so most likely the latest hardwar)

thakoman


[2008-11-19 04:46:39] <Wonka> DocScrutinizer: flashing to moko10-beta2 went though cleanly, i already had working ppp connects with the previously non-working SIM.

[2008-11-19 04:48:24] <Wonka> DocScrutinizer: but there are still problems... more often than not, the GSM chip does not answer. pppd opens the device, gets "AT command interpreter ready", utters "AT\n" and gets nothing. power off, power on, reset on, reset off, try gain... sometimes it works, but mostly not.


O2 UK prepay 3G SIM works with moko10-beta2, was previously not detected. T-mobile UK prepay SIM and old Orange UK contract SIM work with both old and new. Testing so far is cursory at best, but looks good. [quote: Alastair Johnson on devel-ML]

[2008-11-21] I flashed 6 out of our 8 Freerunner V.6 according to the GSM/Flashing- guide. I had no problems and the previously useless 3G- SIMs are working fine now. It seems like the 3G- SIM Issue, our beloved #666, is solved. You should point it out clearly. I heard a lot of users complain about this. The solution is simple and well hidden on the website. By the way, i have new 3G- SIM cards of the following german providers running without problems (O2, T- Mobile, E-Plus, Vodafone). Before the flashing procedure the Vodafone cards were not detected. Good work guys... thanks! Reiner

Works now with new gsm firmware moko10beta2 with O2 in Germany

Very great, I can make calls now after waiting for 5 month, big surprise :). Thanks a lot! --Kevin 15:18, 20 November 2008 (UTC)

Personal tools

i recive instead of

"Program: (34 sectors, 267*8k=2136k) (*******************) ok"

this

"Program: (0 sectors, 0*8k=0k) () ok"

iam currently reflashing the old firmware, that seems to work.

iam using an non-us gsm-freerunner (recived yesterday so most likely the latest hardwar)

thakoman


[2008-11-19 04:46:39] <Wonka> DocScrutinizer: flashing to moko10-beta2 went though cleanly, i already had working ppp connects with the previously non-working SIM.

[2008-11-19 04:48:24] <Wonka> DocScrutinizer: but there are still problems... more often than not, the GSM chip does not answer. pppd opens the device, gets "AT command interpreter ready", utters "AT\n" and gets nothing. power off, power on, reset on, reset off, try gain... sometimes it works, but mostly not.


O2 UK prepay 3G SIM works with moko10-beta2, was previously not detected. T-mobile UK prepay SIM and old Orange UK contract SIM work with both old and new. Testing so far is cursory at best, but looks good. [quote: Alastair Johnson on devel-ML]

[2008-11-21] I flashed 6 out of our 8 Freerunner V.6 according to the GSM/Flashing- guide. I had no problems and the previously useless 3G- SIMs are working fine now. It seems like the 3G- SIM Issue, our beloved #666, is solved. You should point it out clearly. I heard a lot of users complain about this. The solution is simple and well hidden on the website. By the way, i have new 3G- SIM cards of the following german providers running without problems (O2, T- Mobile, E-Plus, Vodafone). Before the flashing procedure the Vodafone cards were not detected. Good work guys... thanks! --Reiner

Works now with new gsm firmware moko10beta2 with O2 in Germany

Very great, I can make calls now after waiting for 5 month, big surprise :). Thanks a lot! --Kevin 15:18, 20 November 2008 (UTC)