Talk:Neo FreeRunner Hardware Issues

From Openmoko

Jump to: navigation, search

For me this is what has worked...

For GPS I can confirm removing sd card allowed my gps to work correct. With card in can not get a fix from interntal antenna, remove card and it works good.

For ATT Sim card radio shack has a go phone for $14 bucks buy it and call att and swap to the new sim card that comes with the go phone. Dont let ratshack activate the go phone. The first store i went to would not let me. The second store asked me and I said no.

--- Low Battery Booting Issue: I can report that I was able to reanimate my FreeRunner having an almost empty battery by pressing the AUX button and then attaching the USB power. A normal boot using the power button was not possible in any battery/USB power configuration, a kernel panic (red blinking LED) always occured.

[jOERG 2008-12-04 10:52] blinking red AUX might be Werner's recent improvements in uBoot testing for sufficient battery power to actually start up kernel. While battery is low, it blinks AUX and charges bat. Eventually it should start Linux kernel, once bat has a reached a certain charge again.


Battery issue

For me it worked to connect the Neo to power source and then boot via aux button, too.

Battery discharges when charging completes

Workaround: I leave this script running in the background to start charging again every half hour if the device is plugged in.



while true;
charger=$(cut -c 1-4 ${charger_type})
if [ ${charger} != "none" ] ; then
echo -n 500 > ${force_usb}
sleep 1800

battery no longer a problem?

I just received my Neo FreeRunner GTA2 in April of '09 and the first thing I did, before reading that it was impossible on this page, was boot it up without a battery in it. I simply plugged in the USB charger and held down the power button until it came on. Perhaps later revisions of the FreeRunner no longer have the discharged-battery can't boot problem? I'd edit the page, but I can only vouch for my one FreeRunner. Hackerb9 20:51, 25 April 2009 (UTC)

Bad device ID in debug board

I've run to the same issue as documented in this thread [1]. My debug board v3 comes from Golden Delicious, shipped at 16 Oct 2009. The vendorID:productID was 0x0403:0x6010 (instead of :0x6001). I fixed this by editing the default ID in ftdi_eeprom's main.c.

So this issue seems to affect more than one piece. Jiri 19:50, 19 November 2009 (UTC)

Personal tools